Installations for IIS on Vista Require SP2

I thought I would document something related to Windows Vista.

If you are developing an installation that will install to Internet Information Services 6.0 on Windows Vista, be aware that you must have Service Pack 2. If you don’t, the installation will probably fail in the middle, and roll back any changes that have been made.

Most developers will only encounter this during testing, because System Administrators will probably already know this, and have SP2 installed on Vista machines.

This issue is frustrating because it’s not spelled out in the installation log. You have to do research on the error shown in the log, and then you find out you need SP2.

 

Be Sociable, Share!

Trackbacks

Leave a Reply

Your email address will not be published. Required fields are marked *